summaryrefslogtreecommitdiff
path: root/portaudio/test/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-25 14:54:53 -0500
committersanine <sanine.not@pm.me>2022-08-25 14:54:53 -0500
commit37c97e345d12f95dde44e1d1a4c2f2aadd4615bc (patch)
treee1bb25bc855883062bdd7847ff2c04290f71c840 /portaudio/test/CMakeLists.txt
parent5634c7b04da619669f2f29f6798c03982be05180 (diff)
add initial structure
Diffstat (limited to 'portaudio/test/CMakeLists.txt')
-rw-r--r--portaudio/test/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/portaudio/test/CMakeLists.txt b/portaudio/test/CMakeLists.txt
new file mode 100644
index 0000000..973568f
--- /dev/null
+++ b/portaudio/test/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Test projects
+# Use the macro to add test projects
+
+MACRO(ADD_TEST appl_name)
+ ADD_EXECUTABLE(${appl_name} "${appl_name}.c")
+ TARGET_LINK_LIBRARIES(${appl_name} portaudio_static)
+ SET_TARGET_PROPERTIES(${appl_name}
+ PROPERTIES
+ FOLDER "Test"
+ )
+ENDMACRO(ADD_TEST)
+
+ADD_TEST(patest_longsine)