summaryrefslogtreecommitdiff
path: root/libs/ode-0.16.1/ode/src/joints/Makefile.am
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-10-01 20:59:36 -0500
committersanine <sanine.not@pm.me>2022-10-01 20:59:36 -0500
commitc5fc66ee58f2c60f2d226868bb1cf5b91badaf53 (patch)
tree277dd280daf10bf77013236b8edfa5f88708c7e0 /libs/ode-0.16.1/ode/src/joints/Makefile.am
parent1cf9cc3408af7008451f9133fb95af66a9697d15 (diff)
add ode
Diffstat (limited to 'libs/ode-0.16.1/ode/src/joints/Makefile.am')
-rw-r--r--libs/ode-0.16.1/ode/src/joints/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/libs/ode-0.16.1/ode/src/joints/Makefile.am b/libs/ode-0.16.1/ode/src/joints/Makefile.am
new file mode 100644
index 0000000..194ef60
--- /dev/null
+++ b/libs/ode-0.16.1/ode/src/joints/Makefile.am
@@ -0,0 +1,37 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/ode/src \
+ -D__ODE__
+
+
+if ENABLE_OU
+
+AM_CPPFLAGS += -I$(top_srcdir)/ou/include
+
+
+endif
+
+
+noinst_LTLIBRARIES = libjoints.la
+
+libjoints_la_SOURCES = joints.h \
+ joint.h joint.cpp \
+ joint_internal.h \
+ ball.h ball.cpp \
+ dball.h dball.cpp \
+ dhinge.h dhinge.cpp \
+ transmission.h transmission.cpp \
+ hinge.h hinge.cpp \
+ slider.h slider.cpp \
+ contact.h contact.cpp \
+ universal.h universal.cpp \
+ hinge2.h hinge2.cpp \
+ fixed.h fixed.cpp \
+ null.h null.cpp \
+ amotor.h amotor.cpp \
+ lmotor.h lmotor.cpp \
+ plane2d.h plane2d.cpp \
+ pu.h pu.cpp \
+ pr.h pr.cpp \
+ piston.h piston.cpp
+